81 MKVI parts


LINCOLN MARK VI 1980 - 1983 WANT TO BUY

User avatar

Posts: 9

Joined: Sun Aug 19, 2012 6:11 pm

Location: Vancouver Island

Post Mon Aug 27, 2012 4:43 am

81 MKVI parts

Hi, I recently aquired an '81 MK VI that looks and sounds wonderful, but needs the ccircuit panel behind electronic iinstrument panel. I have found nothing around here, so have decided to try long distance. I'd love to go road tripping, but can't until I get this piece replaced. Thanx.
User avatar

Posts: 746

Joined: Mon Dec 14, 2009 4:02 am

Location: Primos, Pennsylvania USA

Post Mon Aug 27, 2012 4:48 am

Re: 81 MKVI parts

Hi.
You may just need an ignition switch.
Have you tested the instrument cluster?
John "Old School" Dancy, Primos, Pennsylvania, US
"They're only factory original once."
"All of this is assuming that everything else in the system is stock and well maintained."
"Expearence is the abillity to reconise a misteak befor you mak it agan."
"PROGRESS ... NOT PERFECTION!"
1984(2)|1985|1986|1988|1990(2) Lincoln Mark VIIs

- © Classic Lincolns All rights reserved.
User avatar

Posts: 9

Joined: Sun Aug 19, 2012 6:11 pm

Location: Vancouver Island

Post Tue Aug 28, 2012 6:52 am

Re: 81 MKVI parts

I have the panel out and the copper ribbon on the flexible circuit panel is burned out in a few places.
User avatar

Posts: 746

Joined: Mon Dec 14, 2009 4:02 am

Location: Primos, Pennsylvania USA

Post Tue Aug 28, 2012 5:51 pm

Re: 81 MKVI parts

That is NOT good.

Is your charging system stock and well maintained?

Have you ever replaced the ignition switch?
John "Old School" Dancy, Primos, Pennsylvania, US
"They're only factory original once."
"All of this is assuming that everything else in the system is stock and well maintained."
"Expearence is the abillity to reconise a misteak befor you mak it agan."
"PROGRESS ... NOT PERFECTION!"
1984(2)|1985|1986|1988|1990(2) Lincoln Mark VIIs

- © Classic Lincolns All rights reserved.
User avatar

Posts: 9

Joined: Sun Aug 19, 2012 6:11 pm

Location: Vancouver Island

Post Wed Aug 29, 2012 7:01 pm

Re: 81 MKVI parts

I've only had the car for a couple of months. It had charging issues when I got it, and I did the standard alt, reg, sol, Battery. It still eats power, but the voltage is the same through the whole system.
User avatar

Posts: 746

Joined: Mon Dec 14, 2009 4:02 am

Location: Primos, Pennsylvania USA

Post Fri Aug 31, 2012 7:22 am

Re: 81 MKVI parts

Cool.

Have you ever replaced the ignition switch?
John "Old School" Dancy, Primos, Pennsylvania, US
"They're only factory original once."
"All of this is assuming that everything else in the system is stock and well maintained."
"Expearence is the abillity to reconise a misteak befor you mak it agan."
"PROGRESS ... NOT PERFECTION!"
1984(2)|1985|1986|1988|1990(2) Lincoln Mark VIIs

- © Classic Lincolns All rights reserved.
User avatar

Posts: 9

Joined: Sun Aug 19, 2012 6:11 pm

Location: Vancouver Island

Post Sun Sep 02, 2012 4:40 pm

Re: 81 MKVI parts

No, haven't got to that yet, This panel is definately not functioning. The car runs a nd sounds great, just doesn't charge.
User avatar

Posts: 746

Joined: Mon Dec 14, 2009 4:02 am

Location: Primos, Pennsylvania USA

Post Sun Sep 02, 2012 11:28 pm

Re: 81 MKVI parts

In our 1984 - 1992 Lincoln Mark VIIs, the AMP light is a part of our charging systems.

It's possible that your AMP light bulb is blown. Check it's continuity or just replace it. Check for voltage at the battery while running. Come back here and give us your results.
John "Old School" Dancy, Primos, Pennsylvania, US
"They're only factory original once."
"All of this is assuming that everything else in the system is stock and well maintained."
"Expearence is the abillity to reconise a misteak befor you mak it agan."
"PROGRESS ... NOT PERFECTION!"
1984(2)|1985|1986|1988|1990(2) Lincoln Mark VIIs

- © Classic Lincolns All rights reserved.
User avatar

Posts: 9

Joined: Sun Aug 19, 2012 6:11 pm

Location: Vancouver Island

Post Mon Sep 03, 2012 5:43 am

Re: 81 MKVI parts

The alt is charging fine, but due to the burnt sections in the circuit board are not allowing the system to complete, so I am at the point where I need to replace the circuit before I can check the rest of the system.
User avatar

Posts: 746

Joined: Mon Dec 14, 2009 4:02 am

Location: Primos, Pennsylvania USA

Post Mon Sep 03, 2012 7:16 am

Re: 81 MKVI parts

Gotcha.

Thanks for sharing your experiences with us.
John "Old School" Dancy, Primos, Pennsylvania, US
"They're only factory original once."
"All of this is assuming that everything else in the system is stock and well maintained."
"Expearence is the abillity to reconise a misteak befor you mak it agan."
"PROGRESS ... NOT PERFECTION!"
1984(2)|1985|1986|1988|1990(2) Lincoln Mark VIIs

- © Classic Lincolns All rights reserved.
User avatar

Posts: 9

Joined: Sun Aug 19, 2012 6:11 pm

Location: Vancouver Island

Post Thu Sep 06, 2012 5:27 am

Re: 81 MKVI parts

The light is part of this system as well. I had to have a lengthy discussion with the electrical specialty mechanic at our local ford dealership when I could find no underhood reason for the lack of charge. I've had many a beater with no gauges. :))
User avatar

Posts: 746

Joined: Mon Dec 14, 2009 4:02 am

Location: Primos, Pennsylvania USA

Post Thu Sep 06, 2012 9:30 am

Re: 81 MKVI parts

Cool.
So since we've verified that the AMP light in your 1981 ~IS~ a part of your charging system, have you tested or replaced the bulb?
John "Old School" Dancy, Primos, Pennsylvania, US
"They're only factory original once."
"All of this is assuming that everything else in the system is stock and well maintained."
"Expearence is the abillity to reconise a misteak befor you mak it agan."
"PROGRESS ... NOT PERFECTION!"
1984(2)|1985|1986|1988|1990(2) Lincoln Mark VIIs

- © Classic Lincolns All rights reserved.
User avatar

Posts: 9

Joined: Sun Aug 19, 2012 6:11 pm

Location: Vancouver Island

Post Sun Sep 09, 2012 10:07 pm

Re: 81 MKVI parts

No, I have not tested the bulb. I am still working on the panel repairs

Site Admin

Posts: 133

Joined: Tue Dec 15, 2009 2:03 am

Location: NYC

Post Mon Sep 10, 2012 3:29 pm

Re: 81 MKVI parts

This info might help.
1980 MK 6_0001.jpg

1980 MK 6_0002.jpg

1980 MK 6_0003.jpg

Image

Image

Image
User avatar

Posts: 746

Joined: Mon Dec 14, 2009 4:02 am

Location: Primos, Pennsylvania USA

Post Wed Sep 12, 2012 3:23 am

Re: 81 MKVI parts

NICE!

Thanks for the resource Eddie!
John "Old School" Dancy, Primos, Pennsylvania, US
"They're only factory original once."
"All of this is assuming that everything else in the system is stock and well maintained."
"Expearence is the abillity to reconise a misteak befor you mak it agan."
"PROGRESS ... NOT PERFECTION!"
1984(2)|1985|1986|1988|1990(2) Lincoln Mark VIIs

- © Classic Lincolns All rights reserved.
User avatar

Posts: 9

Joined: Sun Aug 19, 2012 6:11 pm

Location: Vancouver Island

Post Wed Sep 12, 2012 7:03 am

Re: 81 MKVI parts

Thanks, Eddie, but apparently I don't have the necessary permissions required to view the attached files....
User avatar

Posts: 746

Joined: Mon Dec 14, 2009 4:02 am

Location: Primos, Pennsylvania USA

Post Wed Sep 12, 2012 9:07 am

Re: 81 MKVI parts

Temporarily adjusted ;)
John "Old School" Dancy, Primos, Pennsylvania, US
"They're only factory original once."
"All of this is assuming that everything else in the system is stock and well maintained."
"Expearence is the abillity to reconise a misteak befor you mak it agan."
"PROGRESS ... NOT PERFECTION!"
1984(2)|1985|1986|1988|1990(2) Lincoln Mark VIIs

- © Classic Lincolns All rights reserved.
User avatar

Posts: 9

Joined: Sun Aug 19, 2012 6:11 pm

Location: Vancouver Island

Post Thu Sep 13, 2012 12:42 am

Re: 81 MKVI parts

Thank you for the adjustment. Good info, thanks Eddie

Return to LINCOLN MARK VI 1980 - 1983 WANT TO BUY

Who is online

Users browsing this forum: No registered users and 1 guest

cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.